이클립스 sts 플러그인 다운로드

나는 이클립스 4.8 광자를 사용하고 나는 스프링 도구 스위트 룸을 설치하려면. 스프링 툴 스위트의 최소 지원 버전은 4.9이며 이전 모델 스프링 IDE 최대 지원은 4.5까지만 지원됩니다. STS 3을 기존 Eclipse 설치에 설치하려는 경우 또는 업데이트 리포지토리의 호스팅 버전에 액세스하지 않고 기존 STS 3 설치를 업데이트하려는 경우 업데이트 사이트의 보관된 버전을 다운로드할 수 있습니다. 종속성이 충돌하여 설치를 완료할 수 없습니다. 소프트웨어 설치: 스프링 IDE Roo 지원 3.7.3.201602250914-RELEASE(org.springframework.ide.eclipse.roo.roo.feature.group 3.7.3.20) 1602250914-RELEASE) 소프트웨어 현재 설치: 이클립스 플랫폼 4.7.2.v20171130-0510 (org.eclipse.platform.feature.group 4.7.2.v20171130-0510) 브라우저 지원 3.6.100.v20170418-1342 (org.eclipse.ui.browser 3.6.100.v20170418-1342) 브라우저 지원 3.4.200.2010.v330.130.130 org.eclipse.ui.browser 3.4.200.v20131003-1453) 종속성을 충족할 수 없음: From: AspectJ 개발 도구 2.2.4.e44x-20150610 -1600 (org.eclipse.ajdt.feature.group 2.2.4.e44x-20150610-1600) To: org.eclipse.contribution.weaving.jdt 0.. 0.0 의존성을 충족할 수 없음: JDT 직조 2.2.4.e44x-20150610-1600 (org.eclipse.contribution.weaving.jdt 2.2.4.e44x-20150610-1600) : 번들 org.eclipse.ui.browser [3.4.0,3.6.0) 종속성을 충족할 수 없습니다: From: 이클립스 플랫폼 4.7.2. v20171130-0510 (org.eclipse.platform.feature.group 4.7.2.2.v20171130-0510) to: org.eclipse.ui.browser [3.6.100.v20170418-1342] 의존을 충족할 수 없다: 스프링 IDE Roo 지원 3.20.20.20 602250914-RELEASE(org.springframework.ide.eclipse.roo.feature.feature.feature.group 3.7.3.201602250914-RELEASE) To: org.eclipse.ajdt.feature.group 2.0.1 대안으로 STS 3 구성 요소를 기존 스프링 도구 4 설치에 추가 기능으로 설치할 수도 있습니다. 나는 일식 -jee-2019-06-R-win32-x86_64 및 STS 플러그인을 설치 한 후 새로운 봄 프로젝트를 만들기 위해 노력했다. 또 다른 옵션은 https://spring.io/tools 가서 이클립스에 대한 스프링 도구 4의 즉시 사용 분포를 다운로드하는 것입니다, 그것은 최신 이클립스 2018-09 릴리스를 기반으로하고 스프링 도구와 함께 제공 4 사전 설치. 리포지토리 위치가 변경되지 않았는데, 어딘가에 캐시에 오래된 데이터가 있는 것 같아요.

환경 설정으로 이동하여 업데이트 위치를 선택하고 일반적으로 도움이 되는 “다시 로드”를 누를 수 있습니다. 그렇지 않은 경우 기본 설정에서 업데이트 사이트를 제거하고 이클립스를 다시 시작한 다음 다시 추가합니다(기본 설정 -> 설치/업데이트 -> 사용 가능한 업데이트 사이트). 스프링 툴 4에 사용하는 탄력성 번들을 궤도(및 주요 이클립스 분포)에 제공된 것과 동일한 버전으로 업데이트했기 때문에 최신 버전 4.1.2로 수정해야 합니다. 기존 Eclipse 설치에 STS 3을 설치하려면 다음 업데이트 사이트 중 하나를 사용할 수 있습니다. 실행 중인 Eclipse 버전과 일치하는 버전을 선택하십시오: 이 버전은 수정되었으며 다음 업데이트 릴리스의 일부로 제공되며 다음 주에 출시될 예정입니다. 야간 업데이트 사이트를 사용하려는 경우 https://dist.springsource.com/snapshot/TOOLS/sts4/nightly/e4.12 STS4를 이클립스 4.12 설치에 수동으로 설치할 수 있습니다. 나는 아직 시도하지 않았지만, 사용 가능한 업데이트 사이트 환경 설정에이 야간 CI p2 리포지토리를 추가하여 STS4가 포함 된 기존 설치를 업데이트 할 수도 있습니다 .하지만 아직 직접 시도하지는 않았습니다. 이 솔루션의 업데이트 사이트에 도달하려면 이 클립 설치에 이 URL을 추가합니다.

STS4와 이클립스의 이전 버전은 멋지게 우리가 통합 그래프 등의 그래픽보기를 가질 수 있도록, 봄 통합 xmls를 엽니 다 “스프 팅 편집기”를 하는 데 사용됩니다.